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Web Portal - Browsing the Web Portal results in HTTP Error 401.2 Authorization Error 0x80070005 or an error regarding permissions to view this directory or page.

Symptoms

Browsing the web portal immediately returns an error about permissions.

Interface Error - From Remote Server:
You do not have permission to view this directory or page.
 

Interface Error - From Server
HTTP Error 401.2 - Unauthorized
You are not authorized to view this page due to invalid authentication headers.

PMPWeb Log Error:

No logging is possible, as the Web Portal no longer has permission to run.

 

Cause

This occurs when the user account specified to run the web portal is no longer valid, or it's password has changed.

 

Solution

Update the Web Portal's Application Pool  and Directory account username or password within IIS on the Primary Installation.

Windows 2003: These steps only apply to Windows 2008/Vista and later

  1. Open Internet Information Services (IIS)
    Within Start > Administrative Tools open the 'Internet Information Services (IIS) Manager' on the primary installation.


  2. Locate the 'PrintManager' Application Pool
    Within IIS, expand your server and select Application Pools.  Within this should be an Application Pool named 'PrintManager'
  3. Open Advanced Settings on the Application Pool
    Right click on the 'PrintManager' Application Pool and choose [Advanced Settings]


  4. Update Identity
    Locate the setting labeled [Identity] and update the account and password. Ensure it is an account with Administrative rights to the Primary Server, and full control of the Print Manager Plus database.



  5. Locate the Authentication settings for the Print Manager Plus Web Application
    Still within IIS, browse to Sites > PMP > PMPWeb > Authentication


  6. Edit the 'Anonymous Authentication' Identity
    Within Authentication, edit the item named Anonymous Authentication.  Edit the specific user with the same account from step 4.


 

Browsing the website should function as expected.

 

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